Jump to content


Photo

Coil Spring on Driver Side


  • Please log in to reply
7 replies to this topic

#1 cmk033

cmk033

    Member

  • Members
  • 48 posts
  • Gender:Male
  • Location:South Barrington, Illinois, USA
  • Vehicle owned:
    95 Contour LX 2.0

Posted 18 December 2017 - 12:19 PM

Spring on the driver is is broken. I have examined the strut assembly and it does not seem too bad removing the assembly.

 

Has anyone did the strut replacement on this car? I have 95 GL with 2.0 liter engine with automatic trans. If I can get a used strut assembly, I guess I can just replace the driver side only. But buying a 20 years old used strut is questionable.

 

I would think the both side has to be replaced if I am getting a third party parts.

 

Any recommendation input would be appreciated.



#2 mondeoman

mondeoman

    Senior Member

  • Admin
  • 1,081 posts
  • Gender:Male
  • Location:Portland, Oregon
  • Interests:My 1995 Contour GL 2.0 5 spd, is there anything else?
  • Vehicle owned:
    1995 Contour GL 2.0
  • Garage Vehicles:
  • Ford Contour GL (1995)

Posted 19 December 2017 - 06:32 PM

I may still have my front springs from my '95 'Tour with the 2.0 ZETEC and 5spd. Same springs, I suspect. If I can locate them, you may have them for the price of shipping - both of them if you desire.



#3 cmk033

cmk033

    Member

  • Members
  • 48 posts
  • Gender:Male
  • Location:South Barrington, Illinois, USA
  • Vehicle owned:
    95 Contour LX 2.0

Posted 20 December 2017 - 09:44 AM

That would be great. It will require for you to remove the parts.... Would only want the driver side spring. If the strut assembly is in good shape, I would like to have the strut assembly. Let me know if you locate them. Thank you.



#4 mondeoman

mondeoman

    Senior Member

  • Admin
  • 1,081 posts
  • Gender:Male
  • Location:Portland, Oregon
  • Interests:My 1995 Contour GL 2.0 5 spd, is there anything else?
  • Vehicle owned:
    1995 Contour GL 2.0
  • Garage Vehicles:
  • Ford Contour GL (1995)

Posted 05 January 2018 - 08:17 PM

Sorry for the delay...holidays got in the way. Springs were removed from struts. Need to locate them yet.



#5 squeek'ing

squeek'ing

    Junior Member

  • Members
  • 7 posts
  • Vehicle owned:
    1998 Contour SVT #1545

Posted 07 January 2018 - 01:23 AM

I have a set from my 98svt.

#6 cmk033

cmk033

    Member

  • Members
  • 48 posts
  • Gender:Male
  • Location:South Barrington, Illinois, USA
  • Vehicle owned:
    95 Contour LX 2.0

Posted 07 January 2018 - 08:53 AM

Sorry for the delay...holidays got in the way. Springs were removed from struts. Need to locate them yet.

Spring from 98 model would not fit 95~97. Plus the the spring is different depending on the engine size/weight too.


Edited by cmk033, 07 January 2018 - 09:02 AM.


#7 francispennysac

francispennysac

    Member

  • Members
  • 37 posts
  • Gender:Male
  • Location:Allentown
  • Interests:Contours, Guns, Beer :) food
  • Vehicle owned:
    1999 SVT Blk/Tan #2013
  • Garage Vehicles:
  • Ford SVT Contour (1999)

Posted 08 January 2018 - 05:28 PM

Be aware they can be  NIGHTMARE to replace/remove the spring without a QUALITY spring compressor..

 

And if it's rusted you will have a VERY hard time getting the top nut off...



#8 cmk033

cmk033

    Member

  • Members
  • 48 posts
  • Gender:Male
  • Location:South Barrington, Illinois, USA
  • Vehicle owned:
    95 Contour LX 2.0

Posted 08 January 2018 - 07:00 PM

Be aware they can be  NIGHTMARE to replace/remove the spring without a QUALITY spring compressor..

 

And if it's rusted you will have a VERY hard time getting the top nut off...

Thanks for the heads up! I am aware of danger involved in compressing spring to remove from strut assembly. I am not about to go buy the tool but planning on renting it from Advance Auto. I would think that would do.

 

As to the top nut. Is this a problem for all old vehicles or specific to this model. I live in rust prone area and I am always in concern working on older cars because of that. The one I have is 1995 but with only 78K miles on it. The center bold is visible from top. May be I should break lose that bold before removing the strut assembly. What do you think?