Jump to content
Sign in to follow this  
rooster210

question from a new person to the forum.

Recommended Posts

First off, Sorry for my first post being a question but here we go. So I own a 99 cougar. It started its life as an ATX but was converted to MTX in about a week. The past few months I've worked on converting it to a 3.0. So moving ahead.... I got the engine, a 2003 escape engine. When I got the engine there was no intake or cams and the guy I got it from had ported the heads to adapt the 2.5 intake to it. So I took the SVT intake and cams out of my 2.5 and put in it. I also added the fidanza flywheel and headers and exhaust. On top of that it was put together with 8.5:1 forged pistons and rods from a noble. now the problem I'm having is about 6500 rpm the car falls on its face. Could this be from the cams and intake on the escape engine?

Share this post


Link to post
Share on other sites

That is a question a tuner shop may have to answer.  Get a tune done and they will be able to adjust fuel settings to adapt.

Share this post


Link to post
Share on other sites

You have lost power from low CR pistons that were designed for a turbo/blown set up. Most 3.0 owners now agree that the use of stoc 3.0 intakes ,injectors etc will give you the better results...with a good dyno tune..

Share this post


Link to post
Share on other sites

ok thanks Terry. I actually knew what the pistons were designed for when I got them.  I've read many times good turbo builds start from the inside out. I'm just having to do this on a tight budget so just doing everything I want at once wasn't an option. I had expected a little loss in HP compared to what the same engine with higher CR pistons would have but not like this. The car takes off great up to about 4000-4500, pulls very nicely, then its like all at once its pulls leaves and it takes forever for it to climb the rest of the way up. I've only dealt with the 2.5 on these engines so how the 3.0 pulls I'm unfamiliar with, But I'm almost certain it should be a lot better then it is.

The engine is a 2003 escape engine. It was bored slightly out to fit the pistons that I had found for it. Someone was tearing apart the rest of what was left of their noble engine and they put them on e-bay. So stock block, stock crank, forged rods and pistons from the noble. The heads were completely refurbished after porting them to accept the 2.5 lower intake. It was then put together with the SVT lower and upper intake and the SVT cams.

 The 2.5 I took out of the car pulled harder in the area I'm noticing the lack of power and it had 160K miles on it. This and all the SVT parts on a 3.0 hate I've started noticing is what's got me asking about if its possible its the cams and intake.

Share this post


Link to post
Share on other sites

...another point is that hotter SVT cams close the intake valve later...as most know this affects the dynamic CR of any engine and the real cr must be recalculated with a shorter stroke..that is how many degrees after BDC does the intake valve clos and with the use of math we can determine the new shorter stroke ...Static and dynamic are not the same. The SVT intake is overrated for use on a 3.0..also most all turbo engines use a milder cam than a hot nat asp unit...Cam selection on turbo is reverse of hot nat asp engines..

Share this post


Link to post
Share on other sites

My son and I both have turbo contours with 3.0 engines.  We have tried stock 3.0 cams and the SVT cams, and there is more power with the SVT Cams without a noticeable loss of torque.  I had the stock 3.0 cams and just put the SVT's back in.

 

A tune will diagnose your issue, yes it is expensive but so is guessing.

Share this post


Link to post
Share on other sites

..Don, what intake manifolds do you have on your cars?

 

I suggest you check with the owner of Turbo Hoses in Ca, he runs a 3.0 single turbo Noble that makes around 700+Hp and around 600 ft/lbs torque..I don't think he runs stoc SVT cams or intake manifolds..

I should add that this car runs a custom MTX75 in place of the MMT6 gearbox...the trans was built by me...

Share this post


Link to post
Share on other sites

I think its more the intake causing it. Terry after our talk the other day my car has the SVT intake on it with the IMRC removed so I don't have the butterflies in the runner that opens. Also as we had discussed the only reason I put it on was because the intake and cams were missing when I got the engine. It worked out because I got to add the polished SVT intake but its definitely costed some performance I believe. I have a possible lead on one for really cheap so I think I'm going to get it and swap it out since it would only take a couple hours and its done without taking the entire front off the engine. The main problem is the engine has the intake plates on it which you have to port the head and it changes the spot for the injector to actually go in. I'm going to have to build a plate to cover up where the head was ported to put it back to normal. As far as the trans goes, Terry I think you're the only person who will ever work on a trans for me if I need it upgraded I'm calling you.

Share this post


Link to post
Share on other sites

well good news I fixed the problem. it was actually cheap and easy. I had a fault P0340, finally got the chance to get it read. After swapping the cam sensor nothing changed. I swapped the crank sensor as well just in case it was giving a bad reading in conjunction with the cam sensor. Turns out neither was it so I have extras when they go out. What really caused the fault was somehow one of the pins on the ECM itself had actually gotten bent over so when the harness was bolted down the pin pushed over instead of into the harness. I've never seen it happen before so I didn't even think to check that. Cars running amazing now though.

Share this post


Link to post
Share on other sites

Good catch!! Yes, the least likely is sometimes the very thing that corrects a problem. Granted, what is the chance of bending a pin at the ECU....more frequent than one probably thinks. You were lucky these ECU's have high quality pins, as they can snap off upon straigtening w/o any notice ;-) GENTLE is the operative here.

Share this post


Link to post
Share on other sites

yeah the problem with that is the only shop that does it here quoted me almost 750 bucks to tune it .

 

That is a reasonable price for dyno tuning with a SCT X3 included.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.